Autor Thema: Fehlermeldung „Laufzeitfehler 11: Division durch null“  (Gelesen 991 mal)

Offline iberia71

  • Mitglied
  • Beiträge: 43
  • Ort: Frankfurt Ort bei GoogleMaps suchen de
Hallo zusammen,

kürzlich hat meine Festplatte den Geist aufgegeben, wähend WDP geöffnet war. Alle Daten von WDP konnten glücklicherweise gerettet und auf die neue Festplatte übertragen werden. Dennoch scheint irgendetwas schief gegangen zu sein, obwohl alles auf den ersten Blick wunderbar aussieht.

Hier das Problem:

Beim Aufruf des automatischen Fahrbetriebs erscheint die Fehlermeldung „Laufzeitfehler 11: Division durch null“  - genau dann, wenn der erste Zug freie Fahrt bekommt. Der Zug fährt allerdings nicht los und wenn ich das Fenster mit der Fehlermeldung schließe, schließt WDP komplett bzw. stürzt ab. So dass ich das Programm neu starten muss.

Es ist nicht gelungen, das Problem zu beheben. Wer könnte mir weiterhelfen?

Vielen Dank!

Herzliche Grüße
Phil
Rollendes Material: Märklin, Roco, Piko, Lilliput, Brawa.
Fahren überwiegend mit DCC.
  • Win-Digipet-Version:
    WDP 2012.2
  • Anlagenkonfiguration:
    Märklin C- & K-Gleise;  IB II-Win 1.008; Uhlenbrock Verteiler
  • Rechnerkonfiguration:
    Windows 10

Offline Stefan Lersch

  • Betatester
  • Senior-Mitglied
  • *
  • Beiträge: 5668
  • Ort: Brühl (bei Köln) Ort bei GoogleMaps suchen de
    • Infos zum Down-Syndrom alias Trisomie 21
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #1 am: 12. März 2018, 15:15:53 »
Hallo Phil,

beende das WDP-Hauptprogramm und starte die WDP-Datenpflege. Wähle dort “reparieren und komprimieren“.

Hilft das?
Viele Grüße,
Stefan
  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    N-Anlage im Bau, Minitrix & Co., Tams MC 2.1.0, DCC, kabasoft Booster und RMs, Franke-Weichendecoder und Darisus-Multidecoder (Weichen und Signale), Stärz-Kehrschleifen-Module
  • Rechnerkonfiguration:
    Quad Core 8 GB mit Win 10, 32" Bildschirm

Offline iberia71

  • Mitglied
  • Beiträge: 43
  • Ort: Frankfurt Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #2 am: 12. März 2018, 21:45:23 »
Hallo Stefan,

leider hat die Wahl von "reparieren und komprimieren" nichts gebracht. Es ging sofort das Fenster mit der Aussage auf, dass alles repariert sei.

Ich komme mit meinem Problem leider nicht weiter. :-[
Rollendes Material: Märklin, Roco, Piko, Lilliput, Brawa.
Fahren überwiegend mit DCC.
  • Win-Digipet-Version:
    WDP 2012.2
  • Anlagenkonfiguration:
    Märklin C- & K-Gleise;  IB II-Win 1.008; Uhlenbrock Verteiler
  • Rechnerkonfiguration:
    Windows 10

Offline Sven Spiegelhauer

  • Betatester
  • Senior-Mitglied
  • *
  • Beiträge: 6180
  • Ort: Bernau Ort bei GoogleMaps suchen de
    • N-Bahn-Fahrer
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #3 am: 12. März 2018, 22:03:28 »
Hallo Phil,

Du hast in Deinem Profil WDP2012.2 stehen. Das aktuellste Update ist 2012.3! Wurde das Projekt eventuell mit der neueren Version erstellt und Du benutzt eine ältere?
Viele Grüße aus dem schönen Land Brandenburg
Sven
  • Win-Digipet-Version:
    2012 / 2015 / Beta (natürlich alle mit aktuellen Update)
  • Anlagenkonfiguration:
    Spur-N, IB-II, IB-Basic, µCon Booster/Railspeed, Uhlenbrock Loconet-RM/Servo-, Schalt- und MA-Decoder, LDT Schalt- und Lichtsignaldecoder, Lokdecoder(DCC) Tran/ESU/Kühn, Drehscheibendecoder G.Boll und LDT, viele Eigenbauten
  • Rechnerkonfiguration:
    Notebook Win10 optional 2xMonitor(24)

Offline iberia71

  • Mitglied
  • Beiträge: 43
  • Ort: Frankfurt Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #4 am: 12. März 2018, 22:25:12 »
Hi Sven,

nein, das kann nicht sein. Die Versionen sind gleich gewesen.
Rollendes Material: Märklin, Roco, Piko, Lilliput, Brawa.
Fahren überwiegend mit DCC.
  • Win-Digipet-Version:
    WDP 2012.2
  • Anlagenkonfiguration:
    Märklin C- & K-Gleise;  IB II-Win 1.008; Uhlenbrock Verteiler
  • Rechnerkonfiguration:
    Windows 10

Offline Peter Ploch

  • Senior-Mitglied
  • Beiträge: 3775
  • Ort: Neu-Isenburg, Rhein-Main-Gebiet Ort bei GoogleMaps suchen de
    • Modelleisenbahn-Club-Neu Isenburg e.V.
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #5 am: 12. März 2018, 22:47:26 »
Hallo Philipp,

versuche doch einmal von der Installions-CD die Reparatur durch zuführen. Das hat bei mir schon einmal geholfen, allerdings  mit einem anderen Fehlercode.
Viele Grüße aus Neu Isenburg und allzeit HP 1
Peter


Diverses
Homepage von Modelleisenbahnclub Neu Isenburg
skype: hanspeter.ploch
  • Win-Digipet-Version:
    WDP 2018.0b PE
  • Anlagenkonfiguration:
    Märklin C- und K-Gleis, S88 und Booster 3A von Gerd Boll, TAMS MC (V 1.4.8/M3) zum Steuern und Melden, IB -ohne Resets- zum Schalten, Magnetdecoder von Karlheinz Battermann
  • Rechnerkonfiguration:
    HP TouchSmart PC 3,0 GHz, 4,0 GB RAM, Windows 10 (64Bit)

Offline Helmut Kreis

  • Betatester
  • Senior-Mitglied
  • *
  • Beiträge: 4256
  • Ort: Saarland, Kreis Saarlouis Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #6 am: 13. März 2018, 02:19:56 »
Hallo Phil,

kontrolliere mal den Sound-Ordner, ob da Dateien drin sind.

Auch den Hinweis von Sven wieder verfolgen und prüfen, ob Du wirklich alle Updates in WDP hast. Bei einer neuen Installation von WDP hast Du immer nur die Auslieferungs-Software. Die Updates müssen von der Website für die entsprechende Version geladen werden!
Dann auch mal aus dem Startcenter die Programmdateien updaten.
Beide Updates sind verschieden!!!!
« Letzte Änderung: 13. März 2018, 02:28:20 von Helmut Kreis »
Gruß
Helmut
  • Win-Digipet-Version:
    WDP 2018.x PE
  • Anlagenkonfiguration:
    • Gleis: Spur H0, Piko A-Gleis
    • Steuern: Lenz Digital +, LVZ100 u. Interface LI-USB Vers. 3.6, LV102
    • Schalten: Lenz: LS100/110/150, LS-DEC-DB für Lichtsignale, Hoffmann Weichenantriebe MWA02S
    • Melden: GBM16X .. der Fa. Blücher Elektronik, Lenz: LR100, (OpenDCC GBM Boost/GBM16T mit RailCom), RS-Bus + RailCom über LocoNet
  • Rechnerkonfiguration:
    Lenova Touch-PC, Windows 7, 64 bit

Offline Markus Herzog

  • Administrator
  • Senior-Mitglied
  • Beiträge: 11140
  • Ort: Rheinland Ort bei GoogleMaps suchen de
    • markusherzog.ma.funpic.de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #7 am: 13. März 2018, 09:53:13 »
Hallo Phil,

Ist das auch in der Büroversion mit Simulation nachstellbar?
Stell doch mal bitte eine Datensicherung ein mit Angabe der Automatik.

Grüße
Markus

  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    3-Leiter Anlage, Rollendes Material Märklin/Roco/Brawa/Mehano, Fahren: DCC, m3 via Tams MC, Schalten/Melden: Selectrix, BiDiB, Motorola (nur wenige Sonderaufgaben)
  • Rechnerkonfiguration:
    Intel i5

Offline iberia71

  • Mitglied
  • Beiträge: 43
  • Ort: Frankfurt Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #8 am: 13. März 2018, 11:33:01 »
Vielen Dank für alle Antworten.

Ich werde heute Abend Euren Ratschlägen folgen, soweit ich es hinbekomme.

@Markus: Mit der Büroversion kenne ich mich nicht aus. Was meinst Du mit "Angabe der Automatik"?

Viele Grüße
Phil
Rollendes Material: Märklin, Roco, Piko, Lilliput, Brawa.
Fahren überwiegend mit DCC.
  • Win-Digipet-Version:
    WDP 2012.2
  • Anlagenkonfiguration:
    Märklin C- & K-Gleise;  IB II-Win 1.008; Uhlenbrock Verteiler
  • Rechnerkonfiguration:
    Windows 10

Offline Matthias Schäfer

  • Senior-Mitglied
  • Beiträge: 968
  • Ort: Rheinkilometer 644, auf der richtigen Seite Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #9 am: 13. März 2018, 11:38:52 »
Hallo Phil,

wenn Du das Startcenter öffnest, kannst Du Dein aktuelles Projekt in der Anlagenversion starten, d.h., Du kannst Deine MOBA tatsächlich fahren lassen, oder in der Büroversion, damit kannst Du am Rechner den Ablauf "simulieren", ohne daß die Anlage eingeschaltet ist.

In Deinem ersten Beitrag schreibst Du "Beim Aufruf des automatischen Fahrbetriebs....", also hast Du wahrscheinlich eine Zugfahrtenautomatik (ZFA) laufen, und diese möchte Markus genannt haben, damit er gezielt suchen kann.
vielen Dank und herzliche Grüße aus Bonn, Matthias
  • Win-Digipet-Version:
    WDP Premium Edition 2015.2.50
  • Anlagenkonfiguration:
    Märklin K-Gleis, TAMS Version 2.0.1, Vierfach-Booster Battermann, CC-Schnitte mit Mobile Station zum Programmieren, LDT Rückmeldemodule mit Optokoppler,  LDT MA-Decoder mit sep. Spannungsversorgung
  • Rechnerkonfiguration:
    Intel Core i3-2100 3,1 GHz, 8 GB, 64 Bit, Windows 7 prof., Samsung Tablet SM-T555, Android 7.1.1

Offline iberia71

  • Mitglied
  • Beiträge: 43
  • Ort: Frankfurt Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #10 am: 15. März 2018, 14:08:07 »
Hallo,

vielen Dank an alle, die mir hier wertvolle Hinweise gegeben haben. Gestern Abend konnte ich das Problem endlich lösen, nachdem ich das Update im zweiten Anlauf installieren konnte. Die ZGA löst nun tatsächlich wieder Zugfahrten aus. :)

Viele Grüße
Phil
Rollendes Material: Märklin, Roco, Piko, Lilliput, Brawa.
Fahren überwiegend mit DCC.
  • Win-Digipet-Version:
    WDP 2012.2
  • Anlagenkonfiguration:
    Märklin C- & K-Gleise;  IB II-Win 1.008; Uhlenbrock Verteiler
  • Rechnerkonfiguration:
    Windows 10

Offline haraldkern

  • Junior-Mitglied
  • Beiträge: 17
  • Ort: Frankfurt Main Ort bei GoogleMaps suchen de
Re: Fehlermeldung „Laufzeitfehler 11: Division durch null“
« Antwort #11 am: 27. März 2018, 20:09:58 »
Hallo Phil
ich habe nach einem PC Wechsel das gleiche Problem wie du. Laufzeitfehler 11!
Da du auch in Frankfurt wohnst (am Main?) wollte ich mal fragen wie du das problem gelöst hast?
Villeicht kann man sich ja auch mal treffen?
Gruß Harald Kern
Intellibox 1 m. Interface, LDT RMK´s und GBM,
  • Win-Digipet-Version:
    2012 Premium
  • Anlagenkonfiguration:
    DCC
  • Rechnerkonfiguration:
    Windows 7