Autor Thema: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild  (Gelesen 1817 mal)

Offline Guido78

  • Junior-Mitglied
  • Beiträge: 3
  • de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #15 am: 19. Mai 2019, 13:22:09 »
Hallo Zusammen,

ich habe bei mir die gleiche Fehlersituation festgestellt - alllerdings erst seit dem Update auf 2018.1c (Premium Edition).

Ich schalte über mein Gleisbild 48 Magnetartikel über DCC Adressen 401 bis 448. Seit dem Update auf 2018.1c beobachte ich bei jeder Schaltung, dass Artikel mit der Adresse+4 (also bei Schaltung von 401 die Adresse 405, bei Schaltung von 402 die Adresse 406, etc.) virtuell mitgeschaltet werden.

Dabei wir der eigentliche Schaltvorgang (eben virtuell) nicht ausgelöst, hinter den einzelnen K84 Schaltern hängen jeweils einzelne Relais. Auch ich setze die CC-Schnitte mit einer Gleisbox ein. Die Relais steuere ich über einen Arduino Eigenbau an, der auf DCC hört.

Den Haken in den Systemeinstellungen unter "Stellungsanzeige der Magnetartikel bei Eingabe über Zentrale/Handregler/Keyboard" zu entfernen, ist ein funktionierender Workaround (die virtuellen Schaltungen treten nicht mehr auf. Schon mal vielen Dank für den Tipp!), aber offensichtlich keine Dauerlösung - da ich auch die MS2 mit nutzen möchte. Gibt es vielleicht schon neue Informationen?

Viele Grüße
Guido


Offline Markus Herzog

  • Administrator
  • Senior-Mitglied
  • Beiträge: 11600
  • Ort: Rheinland Ort bei GoogleMaps suchen de
    • markusherzog.ma.funpic.de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #16 am: 20. Mai 2019, 22:51:31 »
Hallo Guido,

nein, es gibt keine neuen Infos. Ich habe dazu heute noch mit Torsten Mumm kontaktiert. Er wird dazu mal versuchen an Märklin ranzutreten.

Ja, es kann durchaus sein, dass dies erst seit 2018.1 verstärkt auffällt, da wir (weil es sonst bei anderen Konstellationen/Usern Probleme mit bestimmten Befehlen gab) in Absprache zwischen WDP und Can Digital Bahn verstärkt auf neuere Befehle (aus der Original-Märklin-Doku) umgestellt haben. Und den mag mit der Einstellung DCC die Gleisbox mit einigen Firmware-Versionen wieder nicht bzw. sie reagiert falsch drauf (nämlich wenn Weiche x gestellt, antwortet sie mit einer Handverstellung für Weiche x+4....).
....Trifft leider wieder der Spruch vom Teufel und Belzebub zu anscheinend....

Mal sehen was Märklin dazu sagt. Sollte da nichts kommen, werde ich versuchen den Fehler der Gleisbox auf WDP-Seite im nächsten Update zu kaschieren. Auch wenn das ja eigentlich nicht im Sinne des Erfinders sein kann.

Andere Interims-Lösung wäre Lücken in der Numerierung der Weichen zu machen. 1..4, 9..12 usw.dann gibt es nie eine Weiche+4.

Grüße
Markus
  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    3-Leiter Anlage, Rollendes Material Märklin/Roco/Brawa/Mehano, Fahren: DCC, m3 via Tams MC, Schalten/Melden: Selectrix, BiDiB, Motorola (nur wenige Sonderaufgaben)
  • Rechnerkonfiguration:
    Intel i5

Offline Friedrich Weygand

  • Senior-Mitglied
  • Beiträge: 83
  • Ort: Waren Ort bei GoogleMaps suchen de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #17 am: 21. Mai 2019, 18:32:36 »
Hallo Moba-Kollegen,
ich hänge mich mit einem ähnlich gelagerten Problem an. Ich verwende die Digikeijs DR5000 und habe das Xpressnet in der Schnittstelle eingestellt. Vermutlich seit 2018.1 habe ich auch Geisterschaltungen. Heute nochmal getestet: 160 gr geschaltet --- 159 gr virtuell; 161 gr geschaltet ---- 162 gr virtuell, 154 gr geschaltet ---- 153 gr virtuell, 155 gr geschaltet --- 156 gr virtuell. Schaltet ich dann den Magnetartikel wieder auf rot gibt es keine virtuelle Schaltung. Wenn alle Magnetartikel einmal geschaltet haben, dann gibt es keine Geisterschaltungen mehr. Ich konnte dies damit verhindern, indem ich zu Beginn 2 x nacheinander die Grundstellungen habe ausführen lassen. Ich bin davon ausgegangen, dass meine DR5000 eine "Macke" hat und habe dann in der Schnittstelle Loconet eingestellt und schon sind die "Geisterschaltungen" weg. Das bedeutet für mich, ich kann meine Anlage problemlos betreiben, aber könnte da etwas im Xpressnet-Protokoll der Schnittstelle liegen?
Grüße

Friedrich
  • Win-Digipet-Version:
    WDP 2018.0 c Premium
  • Anlagenkonfiguration:
    Fahren mit Digikeijs DR5000, Schalten und Melden mit RMX/Rautenhaus Module
  • Rechnerkonfiguration:
    Intel I5 8GB Arbeitsspeicher, Win 10

Offline Markus Herzog

  • Administrator
  • Senior-Mitglied
  • Beiträge: 11600
  • Ort: Rheinland Ort bei GoogleMaps suchen de
    • markusherzog.ma.funpic.de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #18 am: 21. Mai 2019, 23:31:10 »
Hallo Friedrich,

die DR5000 sollte man eh im Loconet betreiben, da dann viel mehr Funktionen genutzt werden können. XPressNet-mäßig sollte sich die DR5000 wie die Lenz-Produkte verhalten und da sind keine Probleme bekannt.

Wie gesagt: nutz einfach den Loconet-Mode.

Grüße
Markus
  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    3-Leiter Anlage, Rollendes Material Märklin/Roco/Brawa/Mehano, Fahren: DCC, m3 via Tams MC, Schalten/Melden: Selectrix, BiDiB, Motorola (nur wenige Sonderaufgaben)
  • Rechnerkonfiguration:
    Intel i5

Offline mobafan_H0

  • Senior-Mitglied
  • Beiträge: 266
  • Ort: Rheinland-Pfalz, Kreis Germersheim Ort bei GoogleMaps suchen de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #19 am: 24. Mai 2019, 11:56:58 »
Hallo, ich hab eine Frage zu dieser "Geisterschaltung" soll das ein generelles Problem bei Konstellation "MS2 / Gleisbox 60113 / CC-Schnitte 2.1 generell oder nur bei "einigen" Usern sein ??

Ich habe nämlich auch diese Konstellation und hier bei mir ist da alles ok ??!!

Gruß Arno
Gruß  Arno
  • Win-Digipet-Version:
    WDP 2018.1 Premium Edition
  • Anlagenkonfiguration:
    Märklin C-Cleis, 60113 / m83 / k83 / k84 / CC-Schnitte + GleisreporterdeLuxe
  • Rechnerkonfiguration:
    PC - I5-7400, 64 Bit, Windows 10

Offline V220

  • Senior-Mitglied
  • Beiträge: 292
  • de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #20 am: 24. Mai 2019, 18:58:09 »
Hallo Arno,

welche Gleisformate hast Du unter den Systemeinstellungen für den Verbindungsaufbau freigeschalet?

Dieses Phänomen soll wohl nur unter Verwendung des DCC-Protokoll auftreten, so geht es aus der Antwort  von Markus hervor.

Viele Grüße

Oliver
  • Win-Digipet-Version:
    2018.0b Premium Edition
  • Anlagenkonfiguration:
    Analog: Switch-com Magnet-, Dauerstrom-, Rückmeldedecoder Digital: ECOS II Ver. 4.2.4, Magnetartikel mit Weichenchef über CC-Schnitte, Rückmeldung mit dem CAN-BUS über PC-Schnitte von Thorsten Mumm, µ-Con-Railspeed
  • Rechnerkonfiguration:
    Windows 10 pro, I 7, 16 GB RAM

Offline mobafan_H0

  • Senior-Mitglied
  • Beiträge: 266
  • Ort: Rheinland-Pfalz, Kreis Germersheim Ort bei GoogleMaps suchen de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #21 am: 25. Mai 2019, 08:37:58 »
Hallo Oliver, der "Haken" sitzt bei allen , siehe Bild


Gruß  Arno





Zu diesem Beitrag gehören 1 Anhäng(e). Um diese zu sehen oder zum Download müssen Sie sich einloggen.
Gruß  Arno
  • Win-Digipet-Version:
    WDP 2018.1 Premium Edition
  • Anlagenkonfiguration:
    Märklin C-Cleis, 60113 / m83 / k83 / k84 / CC-Schnitte + GleisreporterdeLuxe
  • Rechnerkonfiguration:
    PC - I5-7400, 64 Bit, Windows 10

Offline Markus Herzog

  • Administrator
  • Senior-Mitglied
  • Beiträge: 11600
  • Ort: Rheinland Ort bei GoogleMaps suchen de
    • markusherzog.ma.funpic.de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #22 am: 25. Mai 2019, 09:45:30 »
Hallo Arno,

schaltest du denn deine Magnetartikel im DCC oder MM-Format (Einstellung im GB-Editor je Magnetartikel). Wenn nur MM-Magnetartikel kein Problem.

Grüße
Markus
  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    3-Leiter Anlage, Rollendes Material Märklin/Roco/Brawa/Mehano, Fahren: DCC, m3 via Tams MC, Schalten/Melden: Selectrix, BiDiB, Motorola (nur wenige Sonderaufgaben)
  • Rechnerkonfiguration:
    Intel i5

Offline mobafan_H0

  • Senior-Mitglied
  • Beiträge: 266
  • Ort: Rheinland-Pfalz, Kreis Germersheim Ort bei GoogleMaps suchen de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #23 am: 25. Mai 2019, 13:13:45 »
Hallo Markus, Oliver,

alle Magnetartikel werden mit MOTOROLA gesteuert bei mir, also KEIN Problem für mich, Ok, Danke


Gruß  Arno
Gruß  Arno
  • Win-Digipet-Version:
    WDP 2018.1 Premium Edition
  • Anlagenkonfiguration:
    Märklin C-Cleis, 60113 / m83 / k83 / k84 / CC-Schnitte + GleisreporterdeLuxe
  • Rechnerkonfiguration:
    PC - I5-7400, 64 Bit, Windows 10

Offline Markus Herzog

  • Administrator
  • Senior-Mitglied
  • Beiträge: 11600
  • Ort: Rheinland Ort bei GoogleMaps suchen de
    • markusherzog.ma.funpic.de
Re: Geisterschaltung eines 2. Magnetartikels im aktiven Gleisbild
« Antwort #24 am: 12. Juni 2019, 23:13:38 »
Hallo zusammen,

Info zum Thema DCC-Magnetartikel-Geisterschaltung der MA-Adresse x + 4 bei SChaltung der MA-Adresse x. Thorsten Mumm hat mir zwischenzeitlich bestätigt, dass er das auch nachvollziehen kann. Er hat dies auch an Märklin weitergegeben als Problem.
Die Frage ist nun wie schnell /ob Märklin reagiert. Hinzu kommt noch das Problem, dass man eine Gleisbox nur an einer CS2/CS3 selbst wenn es ein Update gibt, updaten kann. Die Möglichkeit hat auch nicht jeder.
Von daher werden wir seitens WDP im nächsten Update etwas einbauen um diesen Hardwarefehler zu kompensieren.

Grüße
Markus

P.S.: Ehe die Frage kommt...ein Update kommt wenn es kommt...
  • Win-Digipet-Version:
    WDP 2018.x Beta
  • Anlagenkonfiguration:
    3-Leiter Anlage, Rollendes Material Märklin/Roco/Brawa/Mehano, Fahren: DCC, m3 via Tams MC, Schalten/Melden: Selectrix, BiDiB, Motorola (nur wenige Sonderaufgaben)
  • Rechnerkonfiguration:
    Intel i5